FAQ  •  Login

A workaround for install issues for Blade Runner

Moderator: BR796164

<<

Orffen

Rookie Rep Detect
Rookie Rep Detect

Posts: 1

Joined: Wed Aug 16, 2006 2:24 am

Post Wed Aug 16, 2006 6:21 am

A workaround for install issues for Blade Runner

I was experiencing the same install issues that many seem to be with Windows XP SP2/x64, so I decided to create a new installer using the Nullsoft Install System.

It is a little fiddly (as I'm only providing the script, you'll need to compile it yourself), but it does install the game and it runs without issue afterwards.

I can provide the HDFRAMES.DAT file, which gets created by the Westwood installer when a full install is performed, but I don't have enough space to host it (RAR'ed it is 236MB!).

So, here it is: http://greenwest.actewagl.net.au/blade_nsis.zip

Instructions are included, but if there are any issues, feel free to contact me.
"It's a test designed to provoke an emotional response."

"Is this testing whether I'm a replicant or a lesbian...?"
<<

BR796164

User avatar

Moderator
Moderator

Posts: 1146

Joined: Mon Mar 18, 2002 6:00 pm

Location: Bratislava, Slovakia

Post Mon Sep 04, 2006 2:40 am

Excellent job Orffen! I've been hoping for some geek to make a x64 compatible installer... gonna try it out soon. Also sticking your topic. :wink:
<<

ClickForth

Rookie Rep Detect
Rookie Rep Detect

Posts: 4

Joined: Fri Sep 01, 2006 7:56 pm

Post Mon Sep 04, 2006 9:45 am

How do we contact you? I don't have a copy of HDFRAMES.DAT or Blade.ini, if you can provide those (through AIM filesend...or however you can) that'd be most excellent.
<<

br_collector

User avatar

Senior Rep Detector
Senior Rep Detector

Posts: 125

Joined: Mon May 03, 2004 5:53 pm

Location: Queensland, Australia

Post Sat Nov 10, 2007 7:58 pm

Hi, I've tried what youve said and it isn't working for me, I get the following message in the compiler window:

!define: "MUI_INSERT_NSISCONF"=""

Changing directory to: "C:\Documents and Settings\Matt\My Documents\BASE"

Processing script file: "C:\Documents and Settings\Matt\My Documents\BASE\BLADE.NSI"
Name: "Blade Runner: The Game"
OutFile: "D:\BLADE\Setup Blade Runner.exe"
InstallDir: "$PROGRAMFILES\Blade Runner"
InstProgressFlags: smooth=0, colored=0
Page: directory
Page: instfiles
UninstPage: uninstConfirm
UninstPage: instfiles
Function: ".onInit"
File: "System.dll"->"$PLUGINSDIR\System.dll" [compress] 6029/10240 bytes
Plugin Command: Call kernel32::CreateMutexA(i 0, i 0, t "Blade Runner: The Game") i .r1 ?e
Pop: $R0
StrCmp "$R0" "0" equal=+3, nonequal=
MessageBox: 48: "The installer is already running."
Abort: ""
FunctionEnd
Section: "Installer"
SetOutPath: "$INSTDIR"
File: "BASE\*.*" -> no files found.
Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] |
/oname=outfile one_file_only)
Error in script "C:\Documents and Settings\Matt\My Documents\BASE\BLADE.NSI" on line 30 -- aborting creation process

Could you please help me?
The only crumple zone on a Cobra is the other car
<<

br_collector

User avatar

Senior Rep Detector
Senior Rep Detector

Posts: 125

Joined: Mon May 03, 2004 5:53 pm

Location: Queensland, Australia

Post Sat Nov 10, 2007 9:30 pm

Ok so I fixed that problem, I didn't create the folder "BASE" and it could not locate it. Anyways now I have a new problem:

Processed 1 file, writing output:
Adding plug-ins initializing function... Done!
Processing pages... Done!
Removing unused resources... Done!
Generating language tables... Done!
Generating uninstaller... Done!

Output: "D:\BLADE\Setup Blade Runner.exe"
Can't open output file
Error - aborting creation process

I tried changing the "D:\BLADE\Setup Blade Runner.exe" to "C:\BLADE\Setup Blade Runner.exe" as I dont have a D drive but this did not work.
The only crumple zone on a Cobra is the other car

Return to The Blade Runner Game

Who is online

Users browsing this forum: Bing [Bot] and 1 guest