Page 1 of 1

A workaround for install issues for Blade Runner

PostPosted: Wed Aug 16, 2006 6:21 am
by Orffen
I was experiencing the same install issues that many seem to be with Windows XP SP2/x64, so I decided to create a new installer using the Nullsoft Install System.

It is a little fiddly (as I'm only providing the script, you'll need to compile it yourself), but it does install the game and it runs without issue afterwards.

I can provide the HDFRAMES.DAT file, which gets created by the Westwood installer when a full install is performed, but I don't have enough space to host it (RAR'ed it is 236MB!).

So, here it is:

Instructions are included, but if there are any issues, feel free to contact me.

PostPosted: Mon Sep 04, 2006 2:40 am
by BR796164
Excellent job Orffen! I've been hoping for some geek to make a x64 compatible installer... gonna try it out soon. Also sticking your topic. :wink:

PostPosted: Mon Sep 04, 2006 9:45 am
by ClickForth
How do we contact you? I don't have a copy of HDFRAMES.DAT or Blade.ini, if you can provide those (through AIM filesend...or however you can) that'd be most excellent.

PostPosted: Sat Nov 10, 2007 7:58 pm
by br_collector
Hi, I've tried what youve said and it isn't working for me, I get the following message in the compiler window:


Changing directory to: "C:\Documents and Settings\Matt\My Documents\BASE"

Processing script file: "C:\Documents and Settings\Matt\My Documents\BASE\BLADE.NSI"
Name: "Blade Runner: The Game"
OutFile: "D:\BLADE\Setup Blade Runner.exe"
InstallDir: "$PROGRAMFILES\Blade Runner"
InstProgressFlags: smooth=0, colored=0
Page: directory
Page: instfiles
UninstPage: uninstConfirm
UninstPage: instfiles
Function: ".onInit"
File: "System.dll"->"$PLUGINSDIR\System.dll" [compress] 6029/10240 bytes
Plugin Command: Call kernel32::CreateMutexA(i 0, i 0, t "Blade Runner: The Game") i .r1 ?e
Pop: $R0
StrCmp "$R0" "0" equal=+3, nonequal=
MessageBox: 48: "The installer is already running."
Abort: ""
Section: "Installer"
SetOutPath: "$INSTDIR"
File: "BASE\*.*" -> no files found.
Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] |
/oname=outfile one_file_only)
Error in script "C:\Documents and Settings\Matt\My Documents\BASE\BLADE.NSI" on line 30 -- aborting creation process

Could you please help me?

PostPosted: Sat Nov 10, 2007 9:30 pm
by br_collector
Ok so I fixed that problem, I didn't create the folder "BASE" and it could not locate it. Anyways now I have a new problem:

Processed 1 file, writing output:
Adding plug-ins initializing function... Done!
Processing pages... Done!
Removing unused resources... Done!
Generating language tables... Done!
Generating uninstaller... Done!

Output: "D:\BLADE\Setup Blade Runner.exe"
Can't open output file
Error - aborting creation process

I tried changing the "D:\BLADE\Setup Blade Runner.exe" to "C:\BLADE\Setup Blade Runner.exe" as I dont have a D drive but this did not work.